What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 6 months ago. Mar 27, 2018 - 20:25 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 6 months ago. Mar 26, 2018 - 20:57 UTC
Identified
Something’s not right, but we’re on the case.
Posted 6 months ago. Mar 26, 2018 - 20:28 UTC
Investigating
We’re investigating a potential problem.
Posted 6 months ago. Mar 26, 2018 - 20:05 UTC