What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 19 days ago. Nov 29, 2017 - 16:24 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 20 days ago. Nov 28, 2017 - 17:35 UTC
Identified
Something’s not right, but we’re on the case.
Posted 20 days ago. Nov 28, 2017 - 17:31 UTC
Investigating
We’re investigating a potential problem.
Posted 20 days ago. Nov 28, 2017 - 16:39 UTC