What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Nov 23, 2019 - 13:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2019 - 14:32 UTC
Identified
Something’s not right, but we’re on the case.
Posted Nov 22, 2019 - 14:09 UTC
Investigating
We’re investigating a potential problem.
Posted Nov 22, 2019 - 14:07 UTC
This incident affected: Prezi Next (Online creation & editing, Online collaboration).