What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 6 months ago. Nov 22, 2017 - 10:26 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 6 months ago. Nov 21, 2017 - 10:31 UTC
Investigating
We’re investigating a potential problem.
Posted 6 months ago. Nov 21, 2017 - 10:10 UTC