What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Dec 13, 2019 - 21:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 13, 2019 - 02:09 UTC
Investigating
We’re investigating a potential problem.
Posted Dec 12, 2019 - 20:25 UTC
This incident affected: Prezi Next (Account management).