What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 4 months ago. Jul 10, 2018 - 12:53 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 4 months ago. Jul 09, 2018 - 12:54 UTC
Identified
Something’s not right, but we’re on the case.
Posted 4 months ago. Jul 09, 2018 - 12:32 UTC
Investigating
We’re investigating a potential problem.
Posted 4 months ago. Jul 09, 2018 - 12:29 UTC
This incident affected: Prezi Classic (Account management) and Prezi Next (Account management).