Editor Does not Load
Incident Report for Prezi.com
Resolved
All systems go!
Posted 6 months ago. Mar 26, 2018 - 05:21 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 6 months ago. Mar 25, 2018 - 02:12 UTC
Identified
Something’s not right, but we’re on the case.
Posted 6 months ago. Mar 25, 2018 - 01:16 UTC
Investigating
We’re investigating a potential problem.
Posted 6 months ago. Mar 25, 2018 - 00:44 UTC