What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Jul 16, 2019 - 11:28 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted Jul 15, 2019 - 13:28 UTC