What's going on
Incident Report for Prezi.com
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 08, 2018 - 09:16 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 4 months ago. Jan 05, 2018 - 12:35 UTC
Identified
Something’s not right, but we’re on the case.
Posted 4 months ago. Jan 05, 2018 - 12:25 UTC
Investigating
We’re investigating a potential problem.
Posted 4 months ago. Jan 05, 2018 - 12:19 UTC