Editing and Viewing incident
Incident Report for Prezi.com
Resolved
All systems go!
Posted Jul 11, 2019 - 06:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2019 - 15:12 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 09, 2019 - 15:08 UTC
Update
We are continuing to investigate this issue.
Posted Jul 09, 2019 - 15:07 UTC
Investigating
We are currently investigating this issue.
Posted Jul 09, 2019 - 15:06 UTC