What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 4 months ago. Mar 13, 2018 - 11:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Mar 12, 2018 - 16:20 UTC
Identified
Something’s not right, but we’re on the case.
Posted 4 months ago. Mar 12, 2018 - 15:39 UTC
Investigating
We’re investigating a potential problem.
Posted 4 months ago. Mar 12, 2018 - 15:26 UTC