What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 4 months ago. Apr 01, 2019 - 15:56 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 4 months ago. Mar 31, 2019 - 01:16 UTC
Identified
Something’s not right, but we’re on the case.
Posted 4 months ago. Mar 31, 2019 - 00:34 UTC
This incident affected: Prezi Next (Online prezi creation) and Prezi Classic (Online prezi creation).