What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Jul 15, 2019 - 13:27 UTC
Update
We are continuing to investigate this issue.
Posted Jul 15, 2019 - 13:27 UTC
Update
We are continuing to investigate this issue.
Posted Jul 15, 2019 - 12:52 UTC
Investigating
We’re investigating a potential problem.
Posted Jul 15, 2019 - 12:32 UTC
This incident affected: Prezi Next (Online creation & editing, Account management) and Prezi Classic (Online creation & editing, Account management).