What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Jun 04, 2020 - 16:47 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 04, 2020 - 15:31 UTC
Identified
Something’s not right, but we’re on the case.
Posted Jun 04, 2020 - 14:05 UTC
Investigating
We’re investigating a potential problem.
Posted Jun 04, 2020 - 13:29 UTC
This incident affected: Prezi Design (Online creation & editing), Prezi Next (Online presenting, Online creation & editing, Online collaboration, Live Prezi, Desktop cloud sync, Account management, Analytics), Prezi Classic (Online presenting, Online creation & editing, Online collaboration, Online presentation downloads, Desktop cloud sync, Account management), and Prezi Video (Online creation & editing, Video download).