What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 6 months ago. Jan 15, 2019 - 15:11 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 6 months ago. Jan 14, 2019 - 16:26 UTC
Update
We are continuing to work on a fix for this issue.
Posted 6 months ago. Jan 14, 2019 - 13:44 UTC
Identified
Something’s not right, but we’re on the case.
Posted 6 months ago. Jan 14, 2019 - 09:38 UTC
Update
We are continuing to investigate this issue.
Posted 6 months ago. Jan 14, 2019 - 09:30 UTC
Investigating
We’re investigating a potential problem.
Posted 6 months ago. Jan 14, 2019 - 09:28 UTC
This incident affected: Prezi Classic (Online prezi presenting, Online prezi download).