What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 12 days ago. Dec 06, 2017 - 17:10 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 13 days ago. Dec 05, 2017 - 16:19 UTC
Identified
Something’s not right, but we’re on the case.
Posted 13 days ago. Dec 05, 2017 - 16:06 UTC
Investigating
We’re investigating a potential problem.
Posted 13 days ago. Dec 05, 2017 - 15:59 UTC