What's going on
Incident Report for Prezi.com
Resolved
This incident has been resolved.
Posted 8 months ago. Apr 11, 2018 - 16:02 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 8 months ago. Apr 10, 2018 - 14:42 UTC
Investigating
We’re investigating a potential problem.
Posted 8 months ago. Apr 10, 2018 - 14:39 UTC