What's going on
Incident Report for Prezi.com
Resolved
This incident has been resolved.
Posted 20 days ago. May 01, 2018 - 08:38 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 21 days ago. Apr 30, 2018 - 06:00 UTC
Identified
Something’s not right, but we’re on the case.
Posted 21 days ago. Apr 30, 2018 - 05:57 UTC
Investigating
We’re investigating a potential problem.
Posted 21 days ago. Apr 30, 2018 - 05:56 UTC