What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 23 days ago. Jun 30, 2018 - 08:57 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 23 days ago. Jun 29, 2018 - 11:19 UTC
Identified
Something’s not right, but we’re on the case.
Posted 23 days ago. Jun 29, 2018 - 10:08 UTC
Investigating
We’re investigating a potential problem.
Posted 23 days ago. Jun 29, 2018 - 09:58 UTC