What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Jan 27, 2020 - 12:34 UTC
Update
All systems go!
Posted Jan 27, 2020 - 12:33 UTC
Update
All systems go!
Posted Jan 27, 2020 - 10:16 UTC
Update
We are continuing to investigate this issue.
Posted Jan 27, 2020 - 10:15 UTC
Update
All systems go!
Posted Jan 27, 2020 - 10:15 UTC
Update
Everything looks good now, but we’re monitoring just in case.
Posted Jan 25, 2020 - 09:08 UTC
Update
Something’s not right, but we’re on the case.
Posted Jan 25, 2020 - 09:03 UTC
Investigating
We’re investigating a potential problem.
Posted Jan 25, 2020 - 09:02 UTC
This incident affected: Prezi Present (Account management).