What's going on
Incident Report for Prezi.com
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 15, 2018 - 19:10 UTC
Update
We are continuing to monitor for any further issues.
Posted 4 months ago. Jun 14, 2018 - 20:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Jun 14, 2018 - 20:34 UTC
Update
We are continuing to investigate this issue.
Posted 4 months ago. Jun 14, 2018 - 18:29 UTC
Investigating
We’re investigating a potential problem.
Posted 4 months ago. Jun 14, 2018 - 18:29 UTC
This incident affected: Prezi Classic (Online prezi presenting).