What's going on

Incident Report for Prezi.com

Resolved

All systems go!
Posted Apr 23, 2025 - 07:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2025 - 18:40 UTC

Investigating

We’re investigating a potential problem.
Posted Apr 22, 2025 - 15:07 UTC
This incident affected: Prezi Present (Online presenting, Online creation & editing, Online collaboration, Live Prezi, Desktop cloud sync, Account management, Analytics).