What's going on
Incident Report for Prezi.com
Resolved
This incident has been resolved.
Posted Jun 05, 2019 - 14:33 UTC
Investigating
We’re investigating a potential problem.
Posted Jun 05, 2019 - 14:19 UTC
This incident affected: Prezi Classic (Online presenting, Online creation & editing, Online collaboration).