What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Aug 15, 2019 - 17:29 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted Aug 14, 2019 - 17:38 UTC
Investigating
We’re investigating a potential problem.
Posted Aug 14, 2019 - 17:23 UTC
This incident affected: Prezi Classic (Online presenting).