What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 6 months ago. Mar 30, 2018 - 19:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Mar 29, 2018 - 20:07 UTC
Investigating
We’re investigating a potential problem.
Posted 6 months ago. Mar 29, 2018 - 17:59 UTC