What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Nov 27, 2019 - 23:07 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted Nov 26, 2019 - 22:14 UTC
Update
We are continuing to investigate this issue.
Posted Nov 26, 2019 - 22:05 UTC
Investigating
We’re investigating a potential problem.
Posted Nov 26, 2019 - 22:05 UTC
This incident affected: Prezi Present (Online creation & editing).