What's going on
Incident Report for Prezi.com
Resolved
This incident has been resolved.
Posted 7 months ago. May 30, 2018 - 13:31 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 7 months ago. May 29, 2018 - 13:34 UTC
Investigating
We’re investigating a potential problem.
Posted 7 months ago. May 29, 2018 - 13:24 UTC