Prezi.com login problems
Incident Report for Prezi.com
Resolved
This incident has been resolved.
Posted over 1 year ago. Sep 17, 2016 - 08:11 UTC
Update
We have resolved our login issue, all of our users should be able to login to prezi.com. If you are still experiencing issues please get in touch with us. We are sorry for any inconveniences.
Posted over 1 year ago. Sep 16, 2016 - 13:09 UTC
Update
We are still having technical difficulties. Our team is working hard to resolve it, we will inform you as soon as possible. Thank you very much and we are really sorry for any inconveniences.
Posted over 1 year ago. Sep 16, 2016 - 12:40 UTC
Monitoring
Due to a technical issue some of our users may experience login difficulties to the website. We are working hard to resolve it and get back to you asap. We are really sorry, for any inconveniences.
Posted over 1 year ago. Sep 16, 2016 - 12:28 UTC