What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Jan 14, 2020 - 19:55 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted Jan 13, 2020 - 20:18 UTC
Investigating
We’re investigating a potential problem.
Posted Jan 13, 2020 - 18:52 UTC
This incident affected: Prezi Present (Online creation & editing).