What's going on

Incident Report for Prezi.com

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 14:30 UTC

Monitoring

Everything looks good now, but we’re monitoring just in case.
Posted Mar 10, 2025 - 16:32 UTC

Identified

Something’s not right, but we’re on the case.
Posted Mar 10, 2025 - 16:31 UTC

Investigating

We’re investigating a potential problem.
Posted Mar 10, 2025 - 16:10 UTC