What's going on
Incident Report for Prezi.com
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 12, 2018 - 13:18 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 7 months ago. Dec 11, 2018 - 14:54 UTC
Identified
Something’s not right, but we’re on the case.
Posted 7 months ago. Dec 11, 2018 - 14:38 UTC
Update
We are continuing to investigate this issue.
Posted 7 months ago. Dec 11, 2018 - 14:37 UTC
Investigating
We’re investigating a potential problem.
Posted 7 months ago. Dec 11, 2018 - 14:26 UTC
This incident affected: Prezi Next (Account management) and Prezi Classic (Account management).