What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Oct 28, 2019 - 10:09 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted Oct 27, 2019 - 01:04 UTC
Investigating
We’re investigating a potential problem.
Posted Oct 27, 2019 - 00:52 UTC