What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 22 days ago. Apr 01, 2019 - 15:57 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 25 days ago. Mar 29, 2019 - 14:42 UTC
Identified
Something’s not right, but we’re on the case.
Posted 25 days ago. Mar 29, 2019 - 14:22 UTC
Investigating
We’re investigating a potential problem.
Posted 25 days ago. Mar 29, 2019 - 14:12 UTC
This incident affected: Prezi Classic (Online prezi presenting, Online prezi creation, Account management) and Prezi Next (Online prezi presenting, Online prezi creation, Account management).