What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted about 1 month ago. Aug 22, 2018 - 08:29 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted about 1 month ago. Aug 21, 2018 - 09:35 UTC
Identified
Something’s not right, but we’re on the case.
Posted about 1 month ago. Aug 21, 2018 - 09:13 UTC
Investigating
We’re investigating a potential problem.
Posted about 1 month ago. Aug 21, 2018 - 09:07 UTC