What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 9 months ago. Feb 14, 2018 - 09:41 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 9 months ago. Feb 13, 2018 - 10:52 UTC
Investigating
We’re investigating a potential problem.
Posted 9 months ago. Feb 13, 2018 - 10:33 UTC