What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted Nov 28, 2024 - 18:38 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 28, 2024 - 10:47 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted Nov 28, 2024 - 10:45 UTC
Investigating
We’re investigating a potential problem with account & payment-related actions
Posted Nov 28, 2024 - 10:14 UTC
This incident affected: Prezi Present (Online presenting, Online creation & editing, Online collaboration, Live Prezi, Desktop cloud sync, Account management, Analytics).