What's going on

Incident Report for Prezi.com

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 18:09 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 01, 2026 - 18:07 UTC

Identified

Something’s not right, but we’re on the case.
Posted Jul 01, 2026 - 17:32 UTC
This incident affected: Prezi Video (Online creation & editing), Prezi Design (Online creation & editing), and Prezi Present (Online creation & editing).