What's going on
Incident Report for Prezi.com
Resolved
All systems go!
Posted 11 months ago. Jun 16, 2017 - 09:00 UTC
Monitoring
Everything looks good now, but we’re monitoring just in case.
Posted 11 months ago. Jun 15, 2017 - 10:50 UTC
Identified
Something’s not right, but we’re on the case.
Posted 11 months ago. Jun 15, 2017 - 09:11 UTC
Investigating
We’re investigating a potential problem.
Posted 11 months ago. Jun 15, 2017 - 07:27 UTC